Dec 13, 2011

Eclipse: java.lang.UnsupportedClassVersionError: Bad version number in .class file

Thrown when the Java Virtual Machine attempts to read a class file and determines that the major and minor version numbers in the file are not supported. from Java 6 API

When I checked out project source, the project didn't have .project and .classpath files.
(I'm using Eclipse 3.7.)
So I added Project Facets Java as 1.6 and used JRE1.4 for JRE System Library.
My project is supposed to work on Java 1.4.
But I compiled it with Java 1.6 because Project Facets is Java 1.6.

I fixed Project Facets and Java Compiler version and have no problem.
Post a Comment